tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Паскаль авс.net составить
Паскаль авс.net составить программу с записью дата. программа должна обеспечивать простейшие функции для работы с данными : увеличение/уменьшение на 1 день, ввод значений , вывод значений. .
гиений1509
1 16.06.2019 10:00
1
Ответы
kudgalina83
13.07.2020 07:48
Uses
System;
var
d1, d2: DateTime;
s: string;
begin
Write('Введите дату в формате ДД.ММ.ГГГГ: ');
Readln(s);
d1 := DateTime.Parse(s); { получили дату }
d2 := d1.AddDays(-1);
Writeln('Предыдущий день: ', d2.Day, '.', d2.Month, '.', d2.Year);
d2 := d1.AddDays(1);
Writeln('Следующий день: ', d2.Day, '.', d2.Month, '.', d2.Year);
end.
Тестовое решение:
Введите дату в формате ДД.ММ.ГГГГ: 31.12.2014
Предыдущий день: 30.12.2014
Следующий день: 1.1.2015
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Болыс111
04.10.2019 02:00
Один древнеримский торговец брал несколько раз ссуду в древнеримском банке. каждый раз банкир записывал размер выданной ссуды на листе пергамента, используя римские числа....
OT7
16.02.2021 15:50
Используя законы преобразования логических выражений упростите логическое выражение: F = (¬X → Y) \/ ¬(X → Y)F = ¬((X & Y) \/ ¬Z) → ¬(X & Z)F=¬A \/¬ B \/¬ C \/ A \/...
conyp2005
04.06.2019 11:10
Решить в паскале заданы стоимость различных деталей, выпускаемых мастерской, и их названия. отсортируйте их по стоимости и по алфавиту....
Даниил5702
04.06.2019 11:10
Вводится последовательность из 10 произвольных чисел.определить сколько раз в последовательности встречается число a...
Рост2006
04.06.2019 11:10
Перевести в шестнадцатеричную, восьмеричную и двоичную системы счисления десятичное число 1410...
nikysa1
04.06.2019 11:10
Как можно задать цвета заливки и линий у фигур...
you58
04.06.2019 11:00
Хочу сделать презентацию на тему хатико , но не знаю какой фон сделать...
Danika02
04.06.2019 11:00
Задан список из десяти городов. (array [.]of string)подсчитать количество названий, в которых нет буквы «р»....
ХОРОШИСТ1234567891
04.06.2019 11:00
Program z; var s: real; i,x,n: integer; begin writeln( ввод x,n ); readln(x,n); for i: =n to 1 do s: =s*)*exp(i+1)*ln(1))/exp(i+ln(2*x+; writeln( ответ s= ,s); end. по какой...
10RAM10
04.06.2019 10:50
Как вывести в pascal ответ по модулю: 10^5 + 3 ?...
Популярные вопросы
Начертите координатную прямую и отметьте на ней точки а (5) b ( 1 ) и c...
3
Вкниге 130 страниц. игорь читал 5 дней по 8 страниц, а затем 4 дня по 9...
1
Что такое осётр в рассказе васюткино озеро?...
2
Когда началась первая великая отечественая война...
1
Кто отрицал существование антарктиды?...
3
1.сравните строение дыхательной системы рептилий и амфибий.сделайте вывод.2....
3
Подбирите к слову щедрый стало синоним. сделайте , мне нужно....
3
Как называют зверей которые живут в лесах?...
2
Раздели для переноса: надеваю, пальто, играю....
2
Сочинение на тему что выполучили подарок на 8марта и ваши действии...
2
System;
var
d1, d2: DateTime;
s: string;
begin
Write('Введите дату в формате ДД.ММ.ГГГГ: ');
Readln(s);
d1 := DateTime.Parse(s); { получили дату }
d2 := d1.AddDays(-1);
Writeln('Предыдущий день: ', d2.Day, '.', d2.Month, '.', d2.Year);
d2 := d1.AddDays(1);
Writeln('Следующий день: ', d2.Day, '.', d2.Month, '.', d2.Year);
end.
Тестовое решение:
Введите дату в формате ДД.ММ.ГГГГ: 31.12.2014
Предыдущий день: 30.12.2014
Следующий день: 1.1.2015