ПАСКАЛЬ АБС 8 КЛАСС! Составьте программу, которая запрашивает время в часах (0, 3, 6, 9, 12, 15, 18, 21, 24) и рисует часы с показаниями часовой
стрелки (рис. 3.14).


ПАСКАЛЬ АБС 8 КЛАСС! Составьте программу, которая запрашивает время в часах (0, 3, 6, 9, 12, 15, 18,

АминаКурбанова17 АминаКурбанова17    1   16.02.2021 23:54    39

Ответы
инкндкн инкндкн  19.03.2021 00:01

PascalABC, проще уже некуда

Объяснение:

uses graphABC;

var  h: integer;

begin

 SetWindowSize(400, 400);

 Write('Введите время в часах(0, 3, 6, 9, 12, 15, 18, 21, 24): ');

 ReadLn(h);

 SetPenWidth(2);

 Circle(200, 200, 100);

 Line(200, 200, 200, 103);

 SetPenWidth(5);

 case h of

   0, 12, 24: Line(200, 200, 200, 105);  

   3, 15: Line(200, 200, 295, 200);  

   6, 18: Line(200, 200, 200, 295);  

   9, 21: Line(200, 200, 105, 200);  

 end;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика