Паскаль abc.net дан произвольный текст на языке. написать программу, которая выводит слова, начинающиеся на согласную и заканчивающиеся гласной буквой. ,с комментариями где можно

НикитаГоровой НикитаГоровой    1   02.09.2019 20:20    5

Ответы
// PascalABC.NET 3.2, сборка 1467 от 02.06.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var pic:='\b[бвгджзйклмнпрстфхцчшщъь]\S*[аеёиоуыэюя]\b';
  ReadlnString('Введите:').MatchValues(pic,RegexOptions.IgnoreCase)
      .Println(NewLine)
end.

Пример
Введите: А роза упала на лапу Азора, а Карл у Клары украл кораллы.
роза
на
лапу
Клары
кораллы
ПОКАЗАТЬ ОТВЕТЫ
koretstanya1 koretstanya1  03.08.2020 14:48
Var
   Text,S:string;
   n,k:boolean;
   i:integer;
Begin
Write('Введите текст на русском языке: ');ReadLn(Text);
Text:=LowerCase(Text)+' '; // перевоит текст в нижний регистр
WriteLn(Text); // показывает действие предыдущей строки
For i:= 1 to Length(Text) do
    Begin
    if ('а' <= Text[i])and(Text[i] <= 'я')or(Text[i] = 'ё') then S:=S+Text[i] // записываем русские буквы в S
    else // как только встречаем другой символ, проверяем,
       if Length(S) > 0 then // есть ли в S хоть одна буква,
          Begin // и если есть, то проверяем условие задачки, и выводим слово на экран, если оно истинно
          if (S[1] in 'бвгджзйклмнпрстфхцчшщ')and(S[Length(S)] in 'аоэиуыеёюя') then WriteLn(S);
          S:=''; // далее обнуляем S
          End;
    End;
End.

Пример работы программы:

Введите текст на русском языке: Дан произвольный текст на русском языке. Написать программу, которая выводит слова, начинающиеся на согласную и заканчивающиеся гласной буквой.
дан произвольный текст на русском языке. написать программу, которая выводит слова, начинающиеся на согласную и заканчивающиеся гласной буквой.
на
программу
которая
слова
начинающиеся
на
согласную
заканчивающиеся
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика