Паскаль 34 .паскаль.необходимо составить программу вычисления стоимости покупки с учетом скидки. скидка в 3% предоставляется в том случае, если сумма покупки больше 500 рублей, в 5% — если сумма больше 1 000 рублей. формат входных данных: вводится целое число xx (0≤x≤2 в31 степени −1) — стоимость покупки до скидки. формат выходных данных: выведите стоимость покупки c учетом скидки в рублях с округлением до целых в меньшую сторону.

evstratovamash1 evstratovamash1    3   03.08.2019 15:40    5

Ответы
lilpeeprip2 lilpeeprip2  30.09.2020 12:29
Var st,sk:integer;
begin
readln(st);
if st>1000 
 then sk:=trunc(st*0.95)
 else if st>500 then sk:=trunc(st*0.97)
                else sk:=st;
writeln(sk);
end.

Пример:
3000
2850
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика