Паскаль 1.составить программу которая проверяет четное ли это число 2.составить программу которая уравнивает два числа a и b 3.составить программу которая проверяет трехзначное ли это число

Tema20181234 Tema20181234    1   14.03.2019 20:49    70

Ответы
Zayka1231 Zayka1231  25.05.2020 10:25

1)

var

 num: integer;

begin

 writeln('Введите число');

 read(num);

 if(num mod 2 = 0) then  

   write('Число четное')

 else  

   write('Число нечетное');

end.

2)

var

 a, b, i: integer;

begin

 writeln('Введите a');

 read(a);

 writeln('Введите b');

 read(b);

 if (a > b) then

   swap(a, b);

 for i := 0 to  

 b - a - 1 do

   a := a + 1;

end.

3)

var

 num: integer;

begin

 writeln('Введите число');

 read(num);

 if (num div 1000 = 0) and (num div 100 <> 0) then  

   write('Число трехзначное')

 else  

   write('Число не трехзначное');

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика