Паскаль
1. Напишите программу, которая в последовательности натуральных чисел определяет сумму
чисел, кратных 2 и оканчивающихся на 8. Программа получает на вход целые числа,
количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0
(0 – признак окончания ввода, не входит в последовательность).
В последовательности всегда имеется число, удовлетворяющее условию
Программа должна вывести одно число: сумму чисел, кратных 2 и оканчивающихся на 8.

Nastenkapu Nastenkapu    2   23.04.2020 21:19    4

Ответы
zzzzzzya2017 zzzzzzya2017  13.10.2020 19:24

var a, sum:integer;

begin

writeln('Введите числа (цифра 0 - выход из программы)');

readln(a);

while(a <> 0) do begin

if (((a mod 2) = 0) and ((a mod 10) = 8)) then

 sum:= sum + a;

readln(a);

end;

writeln('Сумма: ', sum);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика