Паскаль•

1) напишите программу, которая определит является ли билет счастливым? билет состоит из 4- чисел. счастливым считается билет, если сумма двух левых цифр равна сумме двух правых цифр.

2) напишите на языке паскаль условие для определения является ли число a положительным и двухзначным и кратным 2

lavin997 lavin997    3   03.11.2019 19:54    4

Ответы
lozinskayaeliz lozinskayaeliz  10.10.2020 11:06

1)

var

n, s1, s2: integer;

begin

Read(n);

s1 := n div 1000 + n div 100 mod 10;

s2 := n mod 10 + n mod 100 div 10;

if s1 = s2 then

Write('Счастливый')

else

Write('Несчастливый');

end.

2) (a mod 2 = 0) and (a > 9) and (a < 100)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика