Паскаль 1-ая девочка купила 3 булочки за Б руб. коп. и 6 конфет за В руб. коп.
2-ая девочка купила 5 булочек за Д руб.коп. и 4 конфеты за Г руб.коп. Написать программу,которая показывает сколько каждая из них заплатила и кто больше

Carolina1Cerry Carolina1Cerry    3   16.12.2020 11:25    3

Ответы
ElectricCat ElectricCat  15.01.2021 11:27

var b,v,d,g,d1,d2:real;

begin

writeln('Б руб: ');

readln(b);

writeln('В руб: ');

readln(v);

writeln('Д руб: ');

readln(d);

writeln('Г руб: ');

readln(g);

if (3*b + 6*v) > (5*d + 4*g) then begin

 writeln('1 девочка заплатила больше');

 d1:=3*b+6*v;

 d2:=5*d+4*g;

 end

 else

   if (5*d + 4*g) > (3*b + 6*v) then begin

   writeln('2 девочка заплатила больше');

   d1:=3*b+6*v;

   d2:=5*d+4*g;

   end

   else if (5*d + 4*g) = (3*b + 6*v) then begin

     d1:=3*b+6*v;

     d2:=5*d+4*g;

     writeln('девочки заплатили одинаково');

     end;

     writeln;

     writeln('1 девочка: ',d1,' руб');

     writeln('2 девочка: ',d2,' руб');

end.


Паскаль 1-ая девочка купила 3 булочки за Б руб. коп. и 6 конфет за В руб. коп. 2-ая девочка купила 5
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика