Pascalabcnet. задайте массив из 10 элементов с датчика случайных двухзначных положительных чисел. a)определите количество четных элементов с четными индексами. выведите на экран исходный массив и полученное количество. б)найдите произведение элементов, кратных 5. выведите на экран исходный массив и полученное произведение.

0Neder0 0Neder0    3   24.08.2019 17:00    1

Ответы
lolkek12398 lolkek12398  09.08.2020 18:55
Var
A:array[1..10] of integer;
k:integer:=0;
Begin
For var i:= 1 to 10 do
    Begin
    A[i]:=random(10,99);
    Write(A[i],' ');
    if (i mod 2 = 0)and(A[i] mod 2 = 0) then k+=1;
    End;
WriteLn;
WriteLn('Количество четных элементов с четными индексами: ',k);
End.

Var
A:array[1..10] of integer;
P:real:=1;
Begin
For var i:= 1 to 10 do
    Begin
    A[i]:=random(10,99);
    Write(A[i],' ');
    if A[i] mod 5 = 0 then P*=A[i];
    End;
WriteLn;
WriteLn('Произведение элементов, кратных 5: ',P);
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика