Pascalabc нужно составить программу для вывода ближайшего степени 2-ки

Barby228 Barby228    2   15.08.2019 00:00    1

Ответы
gltomilovglebnopi gltomilovglebnopi  08.09.2020 14:50
// PascalABC.NET 3.2, сборка 1356 от 04.12.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadInteger('Введите натуральное число:');
  var p:=Round(log2(s));
  Writeln('Два в степени ',p,' = ',power(2,p))
end.

Пример
Введите натуральное число: 4093532
Два в степени 22 = 4194304
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика