Pascalabc.net , решите используя только: int64, begin, var, for, if, end. больше добавлять переменных не надо. 98 теперь, когда торговля в городе процветает, пришло время подумать о перспективах. в вашу казну недавно пришло n поступлений по k сентиннеалей. вы решили инвестировать их в промышленность и рассчитываете на ежегодное увеличение своего вложения в m раз. рассчитайте, сколько сентиннеалей у вас будет через х лет. формат входных данных в первой строке вводится целое число денежных поступлений n (1 < = n < = 100) во второй строке вводится n целых чисел k в строчку, где k - каждое из постулений (1< = k < =10000) в третьей строке вводятся целые числа x и m - количество лет, в течении которых будет накапливаться итоговая сумма (1< = x < =10), и число раз, в которые будет увеличиваться сумма каждый год (2< = m < =12) формат выходных данных выводится целое число, равное итоговой сумме накоплений. примеры входные данные 5 2 2 5 4 2 1 2 выходные данные 30

aleksaprincessa aleksaprincessa    2   07.03.2019 21:24    3

Ответы
kolzov kolzov  24.05.2020 19:30

var

   n, k, x, m: int64;

begin

   readln(n);

   for x := 1 to n do begin

       read(k);

       n += k-1;

   end;

   readln(x, m);

   writeln(n*x*m);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика