Pascal - Задача решить. Составить программу, вычисляющую стоимость покупки с учетом скидки: если покупка превышает 1500 р., то начисляется скидка 3%, если превышает 2000, то начисляется скидка 5%. Выше 4000 - скадка 7%. На вход - стоимость покупки, выход - сколько нужно оплатить.

adimochka adimochka    2   16.01.2021 17:35    9

Ответы
машуля5552 машуля5552  15.02.2021 17:36

var x: real;

begin

  writeln('введите цену товара');

 read(x);

 if x>4000 then x:=x-x*0.07 else

    if x>2000 then x:=x-x*0.05 else

      if x>1500 then x:=x-x*0.03;

    write(x)

     

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика