tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Pascal составить программу
Pascal составить программу с полным ветвлением y=x*x если x< 2 y=x*x*x если x> 2 y=2+x если x=2
bobrovpasha
2 22.09.2019 03:40
4
Ответы
Филипсия
08.10.2020 08:35
Program dfgd;
var
x: integer;
y: real;
begin
write('Введите х: ');
readln(x);
if x < 2
then y := sqr(x)
else
if x > 2
then y := power(x, 3)
else y := 2 + x;
writeln('y=', y);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
pra02
17.04.2021 13:03
Сначала идут примеры, затем сами задания. В конце - как должна выглядеть документ, в целом...
8Lisandra8
12.11.2019 14:18
Рассшифруйте шифр пъётъоя мялтямякя ся рнморэъ зялюлсяьятяль плнмъм если известно одно из слов пещера и ещё какое нибудь остров возможно, не в именительном падеже....
Angelina23411
12.11.2019 14:10
Дан алгоритм в виде фрагмента блок-схемы.запишите его на алгоритмическом языке....
динка84
07.07.2019 14:00
Вследующем фрагменте k и s -переменные целого типа: readln(k); s: =0; while k 0 do begin s: =s+k mod 10; k: = k div 10; end; writeln(s); какая решается ? запрограммируйте...
zuste
07.07.2019 14:00
Перевести из 10-ой с.с в 2-ую число 476...
kseniya1276
07.07.2019 14:00
Сколько бит необходимо,чтобы закодировать 320 различных оттенков цвета?...
незринхорошист2
07.07.2019 14:00
Написать программу вычисления значения переменной а по формуле : a=y²×m-sin(m)...
Tanyams
07.07.2019 14:00
Как число 1101111111101011000110001 перевести из двоичной системы в шестнадцатиричную с объяснениями...
andreykakachnov
22.10.2020 09:56
Unicode кестесинин артыкшылыгы мен кемшилиги...
sashademidova12345
22.10.2020 09:55
160 бит — это Сколько? байт. 2048 байт составляет ? Кбайт. 4 байт — это ? бит. 0,3 Кбайт составляет ? байт. 1,5 Кбайт — это ? бит....
Популярные вопросы
Что ещё кроме названия городо, объясняет миф о споре посейдона и...
3
Рассказ о том что делают в городе зимой...
2
20 карамельный конфет и 30 шоколадных.сколько всего конфет упаковали...
2
Составить рассказ используя опорные выражения: увидеть поздравление...
1
Пути решения экологических проблем каспийского моря...
1
Четверостейшая из стиха с причастным оборотом в начале предложения...
2
На сонной березе щебечут березы.какое из этих слов переносное...
3
Какая синтаксичаская роль деепричастия...
2
Решить автомат станок за 12 минут делает 5 колец,за сколько минут...
3
Вряде чисел 16,5,20,18,4 найдите нечетное число,увеличьте его в 9раз...
2
var
x: integer;
y: real;
begin
write('Введите х: ');
readln(x);
if x < 2
then y := sqr(x)
else
if x > 2
then y := power(x, 3)
else y := 2 + x;
writeln('y=', y);
end.