tutotveti.ru
Предметы
Биология
Физика
Українська мова
Музыка
Французский язык
Обществознание
МХК
Право
ОБЖ
Психология
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Русский язык
Английский язык
Окружающий мир
Алгебра
Другие предметы
История
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Pascal составить программу поиска
Pascal составить программу поиска трех значных чисел, сумма цифр которого равна n
чурка2829
1 19.08.2019 15:00
5
Ответы
COYOT61
08.09.2020 19:57
Var
i, n, s, k: integer;
begin
readln(n);
for i := 100 to 999 do
begin
s := 0; k := i;
while k > 0 do
begin
s := s + k mod 10;
k := k div 10;
end;
if s = n then
writeln(i);
end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Rinyasan
09.12.2019 08:42
Сор номер 1 по информатике 2 четверть 6 класс...
лолодоидтд
09.12.2019 08:41
Вариант 141. найдите объём текста в килобайтах, записанного в кодировке unicode, если он занимает 3 страницы. накаждой странице 52 строки. в каждой строке по 64 символа.2....
03222
09.12.2019 08:40
Записать внутреннее представление десятичного числа 789,254, ...
валентина268
09.12.2019 08:38
Какие виды опций имеет стиль «условное форматирование» и как описываются их функции? 25...
1970даша
08.05.2020 14:26
Запишіть вираз z=|x-2|+3x у 8 степені мовою паскаль...
Maria2006qwerty
08.05.2020 14:26
составить программу написания имени Гриша на кумире чертежник...
andreevochir20
08.05.2020 14:26
Ввести с клавиатуры два натуральных числа и сравнить количество шагов цикла для вычисления их НОД с обычного и модифицированного алгоритмов Евклида....
ruslapanazavr
12.07.2019 02:20
Даны n-чисел, введённых случайным образом. найти сумму и количество отдельно положительных и отрицательных чисел....
danchik56
10.03.2022 07:26
На клетчатой бумаге отметили точки А, В и с. Какой из углов больше: ABC или BCA (рис. 17.14)?...
SVIATOSLAV3000
10.03.2022 07:26
1. Укажите правильные варианты ответов (обвести правильные) (36.) Фосфор- a) Бесцветный газ г) Имеет различную окраску в зависимости от веса 6) Получают из фосфоритов и...
Популярные вопросы
Через что осуществляется связь головного и спинного мозга ...
2
Які події зумовили перетворенню Московії на імперію...
2
Доступ к файлу 1.png, находящемуся на сервере ѕеrver.de, осуществляется...
1
Нравственные основы жизни кроссворд во ответ ...
1
Фрезерный станок массой 263 кг установлен на 4 опорах, средняя площадь...
1
Обчисліть як зміниться швидкість реакції горіння амоніаку, якщо підвищити...
1
Образуйте возвратные глаголы.В каких глаголах суффикс -ся не обозначают...
1
НАПИСАТЬ ЧЕРЕЗ -, РАЗОМ АБО ОКРЕМО Та (й), тому (що), ото (ж) (бо),...
2
Складіть схему : Коли Вкраїну люди покидають ,хіба вони не відають ,...
1
Козлик за лето поправился на 11% осенью похудел на 12% зимой поправился...
3
i, n, s, k: integer;
begin
readln(n);
for i := 100 to 999 do
begin
s := 0; k := i;
while k > 0 do
begin
s := s + k mod 10;
k := k div 10;
end;
if s = n then
writeln(i);
end;
end.