Pascal с двумя 1. составьте программу, вычисляющую сумму квадратов всех чисел от 1 до n 2.напишите программу, определяющую сумму всех нечетных чисел от 1 до 99

virakudleychuk virakudleychuk    2   22.08.2019 14:00    1

Ответы
GangsterSkrillex GangsterSkrillex  05.10.2020 12:41
// PascalABC.NET 3.2, сборка 1383 от 09.02.2017
// Внимание! Если программа не работает, обновите версию!

Задача 1
begin
  Writeln('S=',Range(1,ReadInteger('N=')).Sum(x->x*x))
end.

Пример
N= 10
S=385

Задача 2
begin
  Writeln('S=',Range(1,99,2).Sum)
end.

Результат
S=2500
ПОКАЗАТЬ ОТВЕТЫ
Ijony Ijony  05.10.2020 12:41
1.
var n,i:integer;
begin
readln(n);
for i:=1 to n do writeln(i*i);
end.
2.
var n,i:integer
begin
for i:=1 to 99 do
if i mod 2 = 1 then n+=i;
writeln(n)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика