Pascal (паскаль составить программу сортировки массива методом пузырька но не использовать for только через repeat + использовать flag всего в программе должно быть 3 переменных: i,flag,b: integer; заранее , тому кто свяжусь и отдельно

Anilecchi Anilecchi    2   30.05.2019 15:10    2

Ответы
Feruz2004 Feruz2004  30.06.2020 16:30
Program test;
const n = 5;
var i,flag,b:integer;
m:array [1..n] of integer;
begin
b:=1;
for i:=1 to n do
readln(m[i]);
repeat
b:=b+1;
if m[b]<m[b-1] then
begin
flag:=m[b-1];
m[b-1]:=m[b];
m[b]:=flag;
b:=1;
end;
until b=n;
for i:=1 to n do
writeln(i,')',m[i]);
end.

P.S. я использую for только для записи и вывода
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика