Pascal. паскаль. написать программу, которая меняет знак всех положительных элементов, расположенных в строке и столбце матрицы с максимальным элементом

Alien1712 Alien1712    1   16.06.2019 11:50    4

Ответы
Dhonsina Dhonsina  02.10.2020 02:42
Program gt;
var a:array[1..100,1..100]of integer;
n,m,i,j,max,h,l:integer;
begin
read(n,m);
max:=-maxint;
for i:=1 to n do
for j:=1 to m do
begin
read(a[i,j]);
if(a[i,j]>max)then begin
max:=a[i,j];
h:=i;l:=j;
end;
for j:=1 to m do
a[h,j]:=-a[h,j];
for i:=1 to n do
a[i,l]:=-a[i,l];
a[h,l]:=-a[h,l];
for i:=1 to n do
begin
for j:=1 to m do
write(a[i,j],' ');
writeln;
end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика