Pascal: написать программу расчета количества рулонов обоев шириной d см, если известны длина, ширина, высота комнаты (a,b,c), размеры одного окна (m,n) и одной двери (p,k). ​дверь одна, окно тоже.

kseniaGksenia kseniaGksenia    3   15.11.2019 20:05    5

Ответы
asdx1984 asdx1984  10.10.2020 13:41

var

 a, b, c, d, l, m, n, p, k, r: integer;

 S, u: real;

begin

 writeln('Оклейка комнаты обоями. Все размеры в см.');

 write('Укажи длину, ширину и высоту комнаты: ');

 readln(a, b, c);

 write('Укажи ширину и высоту двери: ');

 readln(p, k);

 write('Укажи ширину и высоту окна: ');

 readln(m, n);

 write('Укажи длину и ширину рулона обоев: ');

 readln(l, d);

 S := 2 * c * (a + b) - p * k - m * n; { площадь оклейки }

 u := l * d; { площадь одного рулона }

 r := Trunc(S / u);

 if Frac(S / u) > 0.05 then

   r := r + 1;

 writeln('Потребуется рулонов: ', r)

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика