Pascal написать программу проверяющую есть ли в заданном слове две подряд идущие одинаковые буквы

olqa252ru olqa252ru    3   06.05.2019 11:03    3

Ответы
2Znanijacom1 2Znanijacom1  30.09.2020 15:47

program raf105;

var  

s:string;

x:boolean;

i:integer;

begin

write('Введите слово: ');

readln(s);

s:= lowercase(s);

for i:=2 to length(s) do

 if not x

   then x:= s[i] = s[i-1];

if x

 then writeln('В слове есть две подряд идущие, одинаковые буквы')

 else writeln('В слове нет двух подряд идущих, одинаковых букв');

end.

Язык PascalABC

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика