Pascal ! дана последовательность натуральных чисел, завершающаяся число 0. определите наибольшую длину монотонного фрагмента последовательности (то есть такого фрагмента, где все элементы либо больше предыдущего, либо меньше). числа, следующие за числом 0, считывать не нужно.

valerunik160val valerunik160val    3   30.08.2019 20:40    5

Ответы
st1rb1t st1rb1t  06.10.2020 05:42
Var A,B,k,Max:byte;
Begin
Max:=1;
Read(A);
B:=A;
Repeat
if A>B then
   Begin
   if k>Max then Max:=k;
   k:=1;
   While (A>B)and(A>0) do
      Begin
      k:=k+1;
      B:=A;
      Read(A);
      End;
   End;
if A<B then
   Begin
   if k>Max then Max:=k;
   k:=1;
   While (A<B)and(A>0) do
      Begin
      k:=k+1;
      B:=A;
      Read(A);
      End;
   End;
if A=B then
   Begin
   if k>Max then Max:=k;
   k:=1;
   B:=A;
   Read(A);
   End;
Until A=0;
if k>Max then Write(k)
else Write(Max)
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика