tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Pascal.дана последовательность
Pascal.дана последовательность чисел .вывести на экран суммы положительных и отрицательных чисел данной последовательности.
Den30001
3 31.07.2019 15:00
1
Ответы
Mikutyan01
03.10.2020 18:42
//Pascal ABC.NET 3.1 сборка 1219
Const
n=10;
Begin
var ar:=ReadArrInteger(n);
writeln('Сумма положительных=',ar.Where(x -> x>0).sum);
writeln('Сумма сумма отрицательных=',ar.Where(x -> x<0).sum);
end.
Пример ввода:
1
-2
3
4
-5
-6
7
8
9
10
Пример вывода:
Сумма положительных=42
Сумма сумма отрицательных=-13
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
TrevorTime
25.09.2021 09:01
Решите на питоне с команды s.find...
nastya892968060
11.09.2019 17:50
Кто такой норберт винер и какова его роль в исследовании информационных процессов? кто такой клод шеннон и чем он знаменит? кем и когда был введен термин «гипертекст»?...
geniip
29.03.2020 19:10
Напечатать таблицу значений функций y=x3 при изменении x от 2 до 12 с шагом напишите программу в Pascal...
Dashasha555
29.03.2020 19:11
Практическая работа Вычисления в электронных таблицах и построение диаграмм Задание Для следующих задач построить таблицы с произвольными данными, например для первой...
201102
13.09.2019 10:50
Решить ! и объяснить) в2 1.для записи текста использовался 64-символьный алфавит. каждая страница содержит 32 строки по 64 символа в строке. какой объем информации (кбайт)...
idrisovbulat
13.09.2019 10:50
Текст занимает 3/4 части страницы.как, не изменяя размера шрифта, отформатировать его,чтобы текст занял всю страницу?...
sunriseliva
16.01.2022 21:52
Очень нужна с решением задания, которое представлено на фото ⬆️ Всего одно задание!...
Katya17507
16.01.2022 21:52
потрібно вставити суфікси :личенько . рученята. святечку.вуличкою....
Топовый1112
16.01.2022 21:52
Один самолёт летел 2 часа а другой-5часов второй самолёт пролетел на 2100км больше первого. Какое расстояние пролетел каждый самолёт если с одинаковой скоростью...
филькатв
16.01.2022 21:53
нужно очень Insert modal verbs can, may, must, should or their equivalents in the necessary tense form:1. Information or data … be stored in the computer’s memory or...
Популярные вопросы
Перечислить полезные ископаемые краснодарского края,добыча которых...
3
Растительная клетка отличается от животной наличием ( какого? )...
2
Один специалист переплел 240 книг за 10дней,а второй столько же за...
3
Периметр треугольника abc равна 15. сторона bc больше стороны ab на...
2
Запеши два прилагательных согласно схеме приставка,корень,окончание...
2
Эссе роль металлов в жизни человека...
3
Найди значение выражений (728×3-2183)×24560 318459×(3000-375×8)...
2
Склонять слово фасфуд на казахском языке...
2
Первая и вторая женщины которые полетели в космос...
3
Один рабочий работал 3 дня по 7 часов в день а другой 2 дня по 8 часов...
1
Const
n=10;
Begin
var ar:=ReadArrInteger(n);
writeln('Сумма положительных=',ar.Where(x -> x>0).sum);
writeln('Сумма сумма отрицательных=',ar.Where(x -> x<0).sum);
end.
Пример ввода:
1
-2
3
4
-5
-6
7
8
9
10
Пример вывода:
Сумма положительных=42
Сумма сумма отрицательных=-13