tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Pascal, цикл while или repeat
Pascal, цикл while или repeat ввести число. получить другое число, путем удаления единиц, сохранив порядок следования оставшихся цифр.
Leprekon11
2 21.08.2019 04:30
1
Ответы
LILIAGNATIV
05.10.2020 08:38
//fromStudent
//без строк
var
n, nn: longint;
i : byte;
function pow (p: longint; k: byte):longint;
var j : byte;
sum : longint;
begin
sum:=1;
if k>0 then for j:=1 to k do sum:=sum*p;
pow:=sum;
end;
begin
write ('Введите число: ');
readln (n);
while n>0 do
begin
if (n mod 10)<>1 then
begin
inc (nn, pow (10, i)*(n mod 10));
inc (i);
end;
n:=n div 10;
end;
write ('Полученное число: ', nn);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
эмирия
27.07.2019 17:50
Дан массив из 10 элементов, заданных случайным образом. вывести его на экран, отсортировать массив по возрастанию и убыванию....
GuardiaN55
21.12.2020 19:26
Команда добавления диаграммы в презентацию программы PowerPoint а) Правка-Добавить диаграммуб) Вставка- Диаграммав)Формат-Диаграмма ...
ekaterina20122
24.08.2021 00:27
Объясните как решить задачу. Скорость передачи данных через некоторое соединение равна 2048000 бит/с. Через данное соединение передают файл размером 1000 Кбайт. Определите...
51bai
24.08.2021 00:28
Здравствуйте с решением задачи, желательно с обЬяснением: Дана постфиксная (обратная польская) запись арифметического выражения: x a + x * b + x * c + x * d + x *...
evelina2023
24.08.2021 09:38
нужно решение данного варианта. Язык: C#...
викусик150
24.08.2021 09:55
HDMI/DVI для чего это нужно?...
doblezor
24.08.2021 10:09
ВОПРОС ПО ТЕМЕ НОУТБУКОВ И КОМПЬЮТЕРОВ НА WINDOWS 10 1)Чем отличается папка Games от папки My Games?2)Программист сам создал папку My Games вручную и запихал туда...
maymiz
06.04.2020 17:58
Марату необходимо нарисовать прямоугольный параллелепипед со сторонами основания 30 см и 40 см, боковое ребро -50 см. Установите правильную последовательность рисования...
mikeman
06.04.2020 17:58
Дана команда: CIRCLE (420,150),25,6, 3.5, 1.2 Назовите значение начала и конца дуги....
MrGromFull
06.04.2020 17:57
PYTHON Напишите программу, которая сравнивает число перестановок элементов при использовании сортировки «пузырьком», методом выбора и алгоритма быстрой сортировки....
Популярные вопросы
Основанием четырехугольной пирамиды KABCD является квадрат со...
1
Наклонились вниз на длинном стебельке белоснежные фарфоровые кольца...
3
Определить сопротивление участка цепи, если сопротивление каждого...
2
Какие пословицы можно писать о весны ...
3
1.В каком предложение слово пишется раздельно? А) Я в)течение...
2
сделать все 5 заданий, нужно только честно...
1
При поглощении света атом А) переходит из состояния с меньшей...
3
Разложите на множители квадратный трехчлен -5x²+6x-1 , используя...
3
Укажіть, який вчений розобив учення про аналізатори:...
3
Запишите какие-нибудь две десятичные дроби,расположенные между...
2
//без строк
var
n, nn: longint;
i : byte;
function pow (p: longint; k: byte):longint;
var j : byte;
sum : longint;
begin
sum:=1;
if k>0 then for j:=1 to k do sum:=sum*p;
pow:=sum;
end;
begin
write ('Введите число: ');
readln (n);
while n>0 do
begin
if (n mod 10)<>1 then
begin
inc (nn, pow (10, i)*(n mod 10));
inc (i);
end;
n:=n div 10;
end;
write ('Полученное число: ', nn);
end.