Pascal / c++ на вход программе два целых числа: n и m, каждое в отдельной строке 0 < n < = 12 0 < = m < 60, указывающие момент времени "n часов m минут". определите наименьшее число полных минут, которое должно пройти до того момента, когда часовая и минутная стрелки ни циферблате совпадут, не обязательно на каком-то делении. вещественную арифметику не использовать. необходимо решить без использования условных операторов (в том числе без тернарного оператора ? : в с++) и\или циклов. кроме того нельзя использовать операции сравнения и логический (булевский) тип данных. примеры входные данные 2 50 выходные данные 26 входные данные 3 0 выходные данные 16

Самира271106 Самира271106    2   22.09.2019 02:50    4

Ответы
сартоваа сартоваа  08.10.2020 08:31
// часовая стрелка: 1 час - 30 град, 2 мин - 1 град
// минутная стрелка: 1 мин - 6 град
// m*6+k*6-360 = (n*60+m+k)/2
var n,m,k:integer;
begin
 readln(n);
 readln(m);
 k:=(60*n-11*m+720) mod 360 div 11;
 writeln(k);
end.

Пример:
2
50
26
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика