Pascal abc.net нужна ! 8) даны натуральное число n и вещественные числа a1, a2, …, an. найти количество вещественных чисел, которые больше своих соседей, т. е. предшествующего и последующего. входные данные во входном потоке в первой строке записано число n (1 < = n < = 10000). во второй строке через пробел записаны n вещественных чисел ai(-10000 < = ai < = 10000). выходные данные в выходной поток следует записать количество вещественных чисел, которые больше своих соседей. пример исходные данные 9 3 -1 12 5 -17 5 2 15 -5 результат 3 9) даны натуральное число n и целый числа a1, a2, …, an. найти количество пар "соседних" чисел ai, равных между собой. входные данные во входном потоке в первой строке записано число n (1 < = n < = 10000). во второй строке через пробел записаны n целых чисел ai(-10000 < = ai < = 10000). выходные данные в выходной поток следует записать количество пар "соседних" чисел ai, равных между собой. пример исходные данные 9 3 -1 -1 5 -17 5 2 2 -5 результат 2 10. даны натуральное число n и целый числа a1, a2, …, an. найти количество пар "соседних" чисел ai , являющихся четными числами. входные данные во входном потоке в первой строке записано число n (1 < = n < = 10000). во второй строке через пробел записаны n целых чисел ai(-10000 < = ai < = 10000). выходные данные в выходной поток следует записать количество пар "соседних" чисел ai , являющихся четными числами. пример исходные данные 10 3 0 4 5 -17 5 2 14 -5 результат 2

Skapisheva15151515 Skapisheva15151515    1   18.09.2019 22:30    14

Ответы
Yarik176 Yarik176  08.10.2020 00:57
8)
// PascalABC.NET 3.3

begin
  var n:=ReadInteger();
  var a:=ReadArrReal(n);
  var k:=a.Where((x,i)->(i>0)and(i<n-1)and
    (a.ElementAt(i)>a.ElementAt(i-1))and(a.ElementAt(i)>a.ElementAt(i+1))).Count;
  Writeln(k);
end.

Пример:
9
3 -1 12 5 -17 5 2 15 -5
3

9)
begin
  var n:=ReadInteger();
  var a:=ReadArrInteger(n);
  var k:=a.Where((x,i)->(i<n-1)and(a.ElementAt(i)=a.ElementAt(i+1))).Count;
  Writeln(k);
end.

Пример:
9
3 -1 -1 5 -17 5 2 2 -5
2

10)
begin
  var n:=ReadInteger();
  var a:=ReadArrInteger(n);
  var k:=a.Where((x,i)->(i<n-1)and(a.ElementAt(i) mod 2=0)and(a.ElementAt(i+1) mod 2=0)).Count;
  Writeln(k);
end.

Пример:
10
3 0 4 5 -17 5 2 14 -5
2
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика