Pascal abc напишите программу, которая сортирует список работников компании по фамилии в алфавитном порядке. в списке не более 10000 строк, ввод заканчивается пустой строкой. входные данные в каждой входной строке записаны данные о сотруднике в формате . фамилия отделяется от инициалов пробелом. ввод заканчивается пустой строкой. выходные данные программа должна вывести список сотрудников в алфавитном порядке, добавив нумерацию. примеры входные данные j.x. smith b.a. weiter a.c. johnes выходные данные 1. a.c. johnes 2. j.x. smith 3. b.a. weiter

ilia39loh ilia39loh    2   30.08.2019 00:10    19

Ответы
Kachelda Kachelda  26.08.2020 12:13
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!

type
  fs=(string,string);

begin
  var L:=new List<fs>;
  repeat
    var aw:=ReadlnString('>').ToWords;
    if aw.Length=0 then break;
    L.Add((aw[1],aw[0]))
  until false;
  var a:=L.OrderBy(t->t[0]);
  var i:=1;
  foreach var x in a do begin
    Writeln(i:4,' ',x[1],' ',x[0]);
    i+=1
    end
end.

Пример
> J.X. Smith
> B.A. Weiter
> A.C. Johnes
>
   1 A.C. Johnes
   2 J.X. Smith
   3 B.A. Weiter
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика