Pascal abc напишите программу, которая определяет количество элементов, сумма цифр которых четна. формат ввода программа получает на вход последовательность целых чисел, заканчивающаяся нулем (0 - признак окончания ввода). формат вывода выведите одно число – количество чисел, сумма цифр которых четна пример ввод вывод 2 4 3 4 1444 4 5 136 0

1анж48 1анж48    1   21.08.2019 20:10    1

Ответы
злючка26 злючка26  14.08.2020 18:19
Program n1;
var a,k: integer;
function summa( n: integer ): integer;
var s: integer;
begin
s:=0;
while n>0 do
begin
s:=s+n mod 10;
n:=n div 10;
end;
summa:=s;
end;
begin
k:=0;
write('введите 1 число: ');
readln(a);
if (summa(a) mod 2=0) and(a<>0) then k:=k+1;
while a<>0 do
begin
write('введите следущее число: ');
readln(a);
if (summa(a) mod 2=0) and(a<>0) then k:=k+1;
end;
writeln('количество: ',k);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика