Pascal.abc дано случайное количество чисел, узнать сколько совершенных чисел в этом ряду (написать программу).

akr999 akr999    3   19.07.2019 06:10    0

Ответы
Arinka26052005 Arinka26052005  07.09.2020 16:20
Var i, k, n, a, sum, kol: Integer;
Begin
   readln(n);
   kol := 0;
   for k := 1 to n do begin
      sum := 0;
      read(a);
      for i := 1 to a-1 do
        if a mod i = 0 then sum := sum + i;
      if sum = a then kol := kol + 1;
   end;
   writeln(kol);
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика