Pascal abc
дан одномерный массив вещественных чисел x(n), составить программу,
которая бы все элементы массива х, начиная с первого положительного
элемента, разделила на два, остальные элементы увеличила на два. элементы
массива ввести с клавиатуры.(змск)

Элла03 Элла03    2   26.11.2019 21:18    8

Ответы
7534558 7534558  10.10.2020 16:14

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

26

27

28

29

30

31

32

33

34

35

36

37

38

39

40

41

uses crt;

const nmax=100;

type mas=array[1..nmax] of real;

var n:byte;

procedure vvod(var a:mas;c:char);

var i:byte;

begin

writeln('Исходный массив ',c);

for i:=1 to n do

begin

a[i]:=-5+15*random;

write(a[i]:5:1)

end;

writeln

end;

procedure poloz(var a:mas;k:real;c:char);

var i:byte;

begin

writeln('Измененный массив ',c);

for i:=1 to n do

begin

if a[i]>0 then a[i]:=a[i]+k;

write(a[i]:5:1)

end;

writeln

end;

var a,b:mas;

k:real;

begin

randomize;

repeat

write('Размер массивов от 2 до ',nmax,' n=');

readln(n);

until n in [2..nmax];

write('Введите число для изменения положительных k=');

readln(k);

vvod(a,'A');

poloz(a,-k,'A');

vvod(b,'B');

poloz(b,k,'B');

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика