Pascal. 1) требовалось написать программу, которая вводит с клавиатуры координаты точки на плоскости (x, y – действительные числа) и определяет принадлежность точки заштрихованной области, включая ее границы. программист торопился и написал программу неправильно. вот она: var x, y: real; begin readln(x, y); if y < = x then if y < = 0 then if y > = x*x-2 then write('принадлежит') else write('не принадлежит'); end. последовательно выполните следующее: 1) пример таких чисел x, y, при которых программа неверно решает поставленную , построить таблицу. 2) укажите, как нужно доработать программу, чтобы не было случаев ее неправильной работы. (это можно сделать несколькими поэтому можно указать любой

alexanrrr alexanrrr    3   01.04.2019 15:41    17

Ответы
bale2017 bale2017  28.05.2020 06:50

1. Примером чисел, которые принадлежат данной области и ошибочно не учитываются данной программой являются числа в 3й четверти выше y=x, например, (-0.5, -0.1), а также в 1-й четверти, например, (1, 1)

2. Программа на Паскале прилагается.


Pascal. 1) требовалось написать программу, которая вводит с клавиатуры координаты точки на плоскости
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика