Pascal. 1.определить количество слов в предложении. 2.определить какая буква в строке встречается чаще: первая или последняя. 3. написать программу меняющую слово "петр" на "иван".

Серёжа331 Серёжа331    3   28.06.2019 07:20    2

Ответы
дарья2411по дарья2411по  22.07.2020 15:24
Для подсчёта слов в предложении, вот код:

program Slova;
var
 s: string;
 r,i:integer;
begin
 writeln('Введите ваше предложение');
 readln(s);
 s:=s+' ';
 for i:=1 to length(s)-1 do
 if (s<>' ') and (s[i+1]=' ') then
 r:=r+1;
 writeln('В предложении ',r, ' слов. ');
 readln;
end.

Какая буква встречается чаще

Program Bykv;
Var s:String;
    i,k1,k2:byte;
Begin
    write('Введите строку: ');readln(s);
    For i:=2 to Length(s)-1 do
     if s[i]=s[1] then inc(k1)
      else if s[i]=s[Length(s)] then inc(k2);
    writeln('Первая буква встречается ',k1);
    writeln('Последняя буква встречается ',k2);
    writeln('Вывод:');
    if k1>k2 then writeln('Первая буква встречается чаще')
     else if k1<k2 then
     writeln('Последняя буква чаще')
      else writeln('Одинаково');
    readln;
End.

Изменить слово петя на иван в строке

program test;
var s,t,z,p:string;j:integer;
begin
writeln('Введите ваше предложение');
readln(s);
write('Введите слово которое хотите заменить: ');
readln(t);
write('Введите замену слову: ', t, ' <> ');
readln(z);
if pos(t,s)<>0 then
j:=pos(t,s);
p:=copy(s,1,j-1);
p:=p+z;
p:=p+copy(s,j+length(t),length(s));
writeln(p);
readln;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика