Парни : d нужно написать программу на паскале что бы она вычисляла сумму значения элементов трехмерного массива тип longin, 2x2x2 (вроде бы,короче че то 2 на 2 : d)

diant020502 diant020502    2   10.09.2019 16:10    4

Ответы
кам81 кам81  07.10.2020 05:39
Если будет ошибка на строчке:
      write('Введите A[' + IntToStr(i) + ',' + IntToStr(j) + ',' + IntToStr(k) + '] = ');
можешь просто убрать ее.
Она может не работать из за разных версий Pascal-я, т.к. не везде есть IntToStr.

--------------------------------------------------------------------

var
  A: array [1..2,1..2,1..2] of longint;
  i, j, k: byte;
  sum: longint;
begin
for i := 1 to 2 do
  for j := 1 to 2 do
    for k := 1 to 2 do
    begin
      write('Введите A[' + IntToStr(i) + ',' + IntToStr(j) + ',' + IntToStr(k) + '] = ');
      ReadLn(A[i, j, k]);
    end;
sum := 0;

for i := 1 to 2 do
  for j := 1 to 2 do
    for k := 1 to 2 do
      sum := sum + A[i, j, k];

writeln('Сумма всех элементов трехмерного массива = ', sum);
readln;
end.

Парни : d нужно написать программу на паскале что бы она вычисляла сумму значения элементов трехмерн
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика