tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Определив подпрограмму нахождения
Определив подпрограмму нахождения максимума из двух чисел, найти максимум из четырех заданных чисел.
nurgi12345
2 22.09.2019 15:10
6
Ответы
АртурЗезарахов
08.10.2020 09:52
С использованием подпрограммы функция:
program Maximum;
var
x1, x2, x3, x4, m: integer;
function max(a, b: integer): integer;
begin
if a > b
then max := a
else max := b
end;
begin
write('Введите 4 числа: ');
readln(x1, x2, x3, x4);
m := max(x1, max(x2, max(x3, x4)));
writeln('Максимальное: ', m);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
dimabos888
21.04.2020 14:47
Запишете внутреннее представление следующих десятичных чисел, используя восьмиразрядного представления целых чиселЭто нужно решить в столбик А) 32Б) -32...
koooooooooo
22.04.2020 05:24
Преимущества и недостатки программных продуктов excel , access...
sasha230200487
22.04.2020 05:27
Составить программу в Паскаль.Очень нужна ваша...
dogtor20
22.04.2020 05:22
Что получится в по след алгаритму использовать чертежник алг рисунок нач смест в точку (1.1) нц 5 раз опустить перо сместится на вектор(1.3) сместится на вектор (1.-3) сместится...
AlzhanovSalavat
22.04.2020 05:18
ответьте на во Отдельный кадр презентации Power Point - это…? 2. Какое имеет расширение файл, содержащий презентацию Power Point? 3. Как называется схема размещения структурных...
chelovekchelovekov99
22.04.2020 05:04
Как по тексту программы определить, какое значение возвращает функция? Приведите пример...
kucm14
22.04.2020 04:44
по информатике Какая таблица истинности соответствует операции дизъюнкции?...
тупой1712
22.04.2020 04:39
1. Истинно или ложно при a := 2; b := 3; c := 4; а. not (a b) б. (a b) and (b c) в. not (a = b) or (c = d) г. (a c) or (b c) and (b a) д. (a b) and (b c) 2. Для каких значений...
t89633261566polypony
21.04.2020 14:47
Задача 1: Ввести с клавиатуры целое числа. Выдать сообщение «число положительное» или нет. program vetvl1; var a:integer; begin writeln( vvod a ); read(a); if a 0 then writeln(‘chislo...
A1my
21.04.2020 14:47
Там три во в сумме должно быть 20 во...
Популярные вопросы
Шеститомное собрание сочинений н.в. гоголя поместили на полку в случайном...
3
Сходство хемосинтеза и фотосинтеза заключается в том что эти процессы: а)характерны...
3
Сколько молекул аммиака nh3 содержится в 68 г его....
2
Как пишется просеянна, или просеяна...
2
Чем вы можете объяснить планы наследника престола александра павловича ввести...
2
49 умножить на 68 плюс 51 умножить на 68 плюс 43 умножить на 12 плюс 51 умножить...
2
Указать склонение и падеж этих слов из деревни к полянке на ветке с ветки...
3
Сумма x и 123 больше числа 46 на 101; найти чему равен x. ответы: 24; 68;...
3
За два дня было вспахано 240 га.во второй день вспахали 7/9 того,что было...
3
Как написать условие 2классав трех клетках 75попугаев. в первой клетке21попугаев,...
1
program Maximum;
var
x1, x2, x3, x4, m: integer;
function max(a, b: integer): integer;
begin
if a > b
then max := a
else max := b
end;
begin
write('Введите 4 числа: ');
readln(x1, x2, x3, x4);
m := max(x1, max(x2, max(x3, x4)));
writeln('Максимальное: ', m);
end.