Определите среднее арифметическое чётных элементов массива a[1..10] написать программу в паскаль

Love2111 Love2111    3   02.10.2019 23:00    4

Ответы
kuzmin06 kuzmin06  09.10.2020 12:42

//Будем считать, что четные по значению

const

 n = 10;

var

 a: array[1..n] of integer;

 i, Sum, Count: integer;

begin

 Sum := 0;

 Count := 0;

 Randomize;

 for i := 1 to n do

 begin

   a[i] := Random(10);

   Write(a[i], ' ');

   if a[i] mod 2 = 0 then

   begin

     Sum := Sum + a[i];

     Count := Count + 1

   end

 end;

 

 Writeln;

 Write('Среднее арифметическое ' +  

       'четных чисел: ', Sum / Count)

end.

ПОКАЗАТЬ ОТВЕТЫ
almiradkzbd almiradkzbd  09.10.2020 12:42

Здесь с четными, а там просто арефмитическое...


Var

m:array [1..100000] of integer;

k,i:integer;

Begin

k:=0;

randomize;

For i:=1 to 10 do

read(m[i]);

For i:=1 to 10 do begin

If m[i] mod 2=0 then

k:=k+m[i] else k:=k+0;end;

k:=k div 10;

writeln(k);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика