tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Определить максимальный
Определить максимальный элемент массива b(размерность 50) и его порядковый номер xi> 0. в паскале.
semabondar200
3 07.06.2019 04:00
5
Ответы
kydaxtaxtax
07.07.2020 01:08
Var
i,imax,max:integer;
b:array[1..50]of integer;
begin
for i:=1 to 50 do
begin
b[i]:=random(100);
write(b[i],' ');
if b[i]>max then
begin
max:=b[i];
imax:=i;
end;
end;
writeln;
writeln('Максимальное число: ',max,'; его номер: ',imax);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
KaKOYTAGHOM
17.04.2019 02:23
Даны 3 числа меньшее из них возвести в квадрат формата бит...
alisgrhf
17.04.2019 02:38
Найдите ошибку и исправьте, чтобы программа заработала. ❤️...
iPadmaksi123
01.09.2019 14:20
Операторы в языке программирования паскаль отделяются а)двоеточием б) прямоугольник г)параллелограмма д)овал...
serpgo1
01.09.2019 14:20
Проанализируй и запиши ответ, если a=3; b=17 ....
karinakatushkiowsqqh
01.09.2019 14:20
Определите значение переменной а после выполнения алгоритма а: =4 b: =2 b: =a/2*b a: =2*a+3*b в ответе укажите одно целое число - значение переменной а...
Dashamudrik123
01.09.2019 14:20
Файл размером 2500 кбайт передаётся через некоторое соединение в течение 2 минут. определите размер файла (в кбайт), который можно передать через это соединение за 72 секунды. в...
aleksaptikeev
01.09.2019 14:30
Какая функция работы с текстом не предусмотрена в блокноте...
seetneek
01.09.2019 14:30
Изобразите элемент как базовый блок и значение функции через значения на входах...
Evelina0889
01.09.2019 14:30
Написать программу получить степени a: a,a^2, меньше чем b делать в pascal abc,...
Мария12Мария12
01.09.2019 14:30
Запишите структуру программы turbo pascal...
Популярные вопросы
1. расположите в хронологической последовательности события. запишите цифры, которыми...
1
На клумбе распустилось 6 роз, 4 георгины, а астр на 2 больше, чем роз и георгины...
3
Чему равна максимальная погрешность измерния диномометра...
3
Какое количество теплоты выделится за 1 час в обмотке реостата сопротивлением...
3
Втреугольнике авс сторона ав=5 см. , угол с=30, угол в=45. решите треугольник...
3
Какой была начальная скорость поезда, если через 50 с , двигаясь с ускорением...
1
Кто чем может) 1. полный контроль государства над жизнью каждого гражданина осуществляется...
2
Почему буква ee читается по разному...
3
Проспрягать глагол to be в present simple. проспрягать глагол to be в past simple....
3
Вопрос по обж: чем объяснить сохранение тепла в снежной пещере 27 ))...
1
i,imax,max:integer;
b:array[1..50]of integer;
begin
for i:=1 to 50 do
begin
b[i]:=random(100);
write(b[i],' ');
if b[i]>max then
begin
max:=b[i];
imax:=i;
end;
end;
writeln;
writeln('Максимальное число: ',max,'; его номер: ',imax);
end.