Очень Задачи необходимо написать на языке Паскаль….

2.9. Три шахматиста играют в шахматы. Известно количество очков, набранных каждым из них. Составить программу, которая определит, на сколько очков победитель оторвался от самого слабого игрока.

3.10. На склад поступают груза на машинах различной грузоподъемности. Одновременно на компьютер, обслуживающий склад, поступает информация о весе груза на каждой машине. Составить программу, определяющую количество машин, прибывших с грузом до полного заполнения склада, если известно, что склад вмещает 1000 тонн груза.

igorbrekk igorbrekk    2   17.07.2021 13:13    8

Ответы
bakulya2005ma bakulya2005ma  16.08.2021 13:30

В 2.9 нужно, как я понял, просто вычесть из кол-ва очков победителя кол-во очков самого слабого игрока.

В 3.10 - не совсем понятно как получаем данные. Вводятся вручную или уже загружены заранее? В любом случае можно сделать через цикл (для простоты напишу на питоне программу с ручным заполнением):

i = 0

while i < 1000:

   a = int(input())

   i += a

   print("Склад заполнен на ", i / 1000 * 100, "% (", i, ")")   #опционально

P.S. Паскаль не помню, извини.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика