очень Составить программу на языке Паскаль и записать в тетрадь по алгоритму

Алгоритм решения линейного уравнения ах=в, где а и в произвольные вещественные числа

алг линейноеуравнение

арг а,в

рез х,у

нач

если а≠0

то у:= «есть решение» х:=в/а

иначе если в=0 то у:= «х-любое число» иначе у:= «решений нет»

всё

всё

кон

navozovaleksejj navozovaleksejj    3   20.05.2020 16:14    3

Ответы
Piragovicch Piragovicch  30.08.2020 08:19

var

a, b, x,y:Real;

begin

ReadLn(a, b);

if (a<0) or (a>0) then

begin

y:= b/a;

WriteLn(y);

end

else if (b<0) or (b>0) then

WriteLn('Решений нет')

else

WriteLn('x-любое число');

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика