очень Написать программу в Pascal:
В одномерном МАССИВЕ введённом с клавиатуры определить сколько элементов имеет отрицательный индекс, сколько ненулевых элементов в массиве, рассчитать среднее значение положительных элементов.( Все эти условия должны быть в одной программе, и с массива)Если я буду очень благодарен

lisofoxi lisofoxi    2   25.02.2020 15:56    5

Ответы
lilaorazova2003 lilaorazova2003  11.10.2020 12:52

program masss;

var

a:array[-5..5] of integer;

i,oi,n0,s: integer;

begin

oi:=0;n0:=0; s:=0;

for i:=-5 to 5 do

begin

read(a[i]);

if i<0 then inc(oi);

if a[i]<>0 then inc(n0);

if a[i]>0 then s:=s+a[i];

end;

writeln('элементы с отрицательным индексом》',oi);

writeln('ненулевых элементов в массиве》',n0);

writeln('среднее значение положительных элементов》',s/11);

readln;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика