очень надо. Пришлите либо фото либо напишите программу здесь очень надо. Пришлите либо фото либо напишите программу здесь ">

face29 face29    1   27.05.2020 16:28    3

Ответы
стефания31 стефания31  18.08.2020 23:50

var a:integer;

begin

   write('Введите трёхзначное число: ');

   readln(a);

   if (a >= 100) and (a <= 999) then

       writeln((a div 100) + (a mod 10))

   else writeln('Ошибка! Это не трёхзначное число.');

end.


очень надо. Пришлите либо фото либо напишите программу здесь очень надо. Пришлите либо фото либо нап
ПОКАЗАТЬ ОТВЕТЫ
мэривип мэривип  18.08.2020 23:50
var s,n: integer;beginread(n);s := n div 100 + n mod 10;write(s);end.

или более гибкий вариант, складывает первую и последнюю цифру числа независимо от того, трёхзначное число или нет:

var n: integer;beginread(n);Print(n.ToString.First.ToDigit + n.ToString.Last.ToDigit);end.

Пример работ:


очень надо. Пришлите либо фото либо напишите программу здесь очень надо. Пришлите либо фото либо нап
очень надо. Пришлите либо фото либо напишите программу здесь очень надо. Пришлите либо фото либо нап
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика