, очень надо. Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 7 и оканчивающихся на 1. Программа получает на вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность). Введенные числа не превышают 300. Программа должна вывести одно число: сумму всех чисел, подходящих по условию.

кто-нибудь, умоляю 20б паскаль

lcjewfyjozo075 lcjewfyjozo075    3   28.04.2021 23:41    8

Ответы
LuxAeterna LuxAeterna  28.04.2021 23:50

var

sum,chislo:integer;

begin

while true do

begin

readln(chislo);

if chislo=0 then break;

if (chislo mod 7=0) and (chislo mod 10 = 1) then

sum+=chislo;

end;

writeln(sum);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика