Оч надо. прям сейчас ♥♥♥ составить программу, которая заданные числа вводит в массив и вычисляет сумму всех элементов массива.

mariapopova77 mariapopova77    3   12.09.2019 00:10    2

Ответы
яна2754 яна2754  07.10.2020 08:33
// PascalABC.NET 3.3, сборка 1583 от 25.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ReadArrInteger(ReadInteger('n='));
  Writeln('Сумма чисел равна ',a.Sum)
end.

Пример
n= 10
23 14 -5 16 0 32 -12 4 -6 -2
Сумма чисел равна 64
ПОКАЗАТЬ ОТВЕТЫ
Yaroslava0111 Yaroslava0111  07.10.2020 08:33
Const Sz = 100; // Размер массива

var
a: array [1..Sz] of integer;
N: integer; // Количество элементов в массиве
i: integer;

begin
write('Введите количество элементов в массиве: ');
readln(N);
write('Введите элементы массива: ');
for i:=1 to N do
read(a[i]);
write('Вывод элементов массива: ');
for i:=1 to N do
write(a[i],' ');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика