Обращаюсь к информатикам!
Составить программу в Паскале для обработки одномерного массива из 15 чисел. Значения элементов массива задать с клавиатуры самостоятельно. Найти наименьший элемент массива и его номер.
Заранее огромное

alkasalamatina alkasalamatina    3   08.04.2020 10:51    7

Ответы
jonhcenapampam22222 jonhcenapampam22222  12.10.2020 22:24

Pascal ABC

Код:

var

  a: array [1..15] of integer;

  i, min: integer;

begin

    //заполнение массива

    for i := 1 to 15 do

        readln(a[i]);

    //поиск минимума

    min := 1;

    for i := 1 to 15 do

        if a[min] > a[i] then min := i;

    //вывод минимального и его номера

    writeln('Минимум: ', a[min], ' Номер: ', min);

end.

Тесты:

Ввод:

4 5 7 8 9 2 1 3 4 5 8 7 6 8 2

Вывод:

Минимум: 1 Номер: 7

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика