нужно, заранее ) Составить алгоритм через программу С++
 дано трехзначное целое число. Составить программу, которая определяет, является ли произведение цифр числа двузначным числом;
 дано четырехзначное число. Составить программу, которая определяет, какие цифры этого числа четные, а какие нечетные. Число вводить с клавиатуры;
 составить программу, которая определяет, делится ли одно целое число на другое без остатка. Числа вводить с клавиатуры.

vikasaaan vikasaaan    1   26.03.2021 07:09    25

Ответы
natulina2009 natulina2009  25.04.2021 08:10

//1

#include <iostream>

using namespace std;

signed main() {

int N, pr = 1;

cin >> N;

N = abs(N);

if ((N % 10 * (N / 10) % 10 * N / 100) > 10 and (N % 10 * (N / 10) % 10 * N / 100) < 100)

 cout << "YES";

else

 cout << "NO";

return 0;

}

//2

#include <iostream>

using namespace std;

signed main() {

setlocale(LC_ALL, "Rus");

int N;

cin >> N;

N = abs(N);

while (N > 0) {

 if ((N % 10) % 2 == 0)

  cout << N % 10 << " - четное\n";

 else

  cout << N % 10 << " - нечетное\n";

 N /= 10;

}

return 0;

}

//3

#include <iostream>

using namespace std;

signed main() {

setlocale(LC_ALL, "Rus");

int a, b;

cin >> a >> b;

if (a % b == 0)

 cout << "Число " << a << " делится без остатка на число " << b;

else

 cout << "Число " << a << " не делится без остатка на число " << b;

return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика