Нужно в паскале. напишите программу которая вводит с клавиатуры числа до тех пор пока не будет введено число 0. в конце работы программы на экран выводится сумма и произведение введенных чисел (не считая 0).

saaangelina saaangelina    2   07.10.2019 15:40    14

Ответы
жанат17 жанат17  10.10.2020 01:53

Program n_1;

var a, b, n: double;

begin

   read (n);

   a:=n; b:=n;

   if n<>0 then read (n);

   while (n<>0) do begin

       a:=a+n;

       b:=b*n;

       read(n);

   end;

   writeln('Сумма чисел равна ', a:0:10, ' а их произведение ', b:0:10);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика