Нужно составить программу в турбо паскаль, которая находит минимальный элемент в массиве и ставит его на первое место, при этом все остальные элементы сдвигаются. вывести на экран новый массив.

petrenkof1 petrenkof1    3   20.07.2019 07:50    2

Ответы
мая101 мая101  03.10.2020 08:36
Const n = 10;
var a:array[1..n]of integer;
  min,imin,i,oldmin:integer;
begin
  //Заполнение массива значениями в диапазоне
  //от -100 до 100
  //и одновременно находим минимальный элемент элемент
  min:=100;
  for i:=1 to n do begin
    a[i]:=random(201)-100;
    if a[i]<= min then
    begin
      min:=a[i];
      imin:=i;//Запомним index минимального
    end;
    write(a[i]:5);
  end;
  writeln;
 
  //В цикле сдвигаем элементы массива
  //до индекса минимального включительно на
  //одну позицию вправо
  for i:=imin downto 2 do
    a[i]:=a[i-1];
    a[1]:=min;
  //вывод элементов массива
  for i:=1 to n do write(a[i]:5);
 end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика