нужно составить программу в паскале
Заранее Задание:
Найдите среднее арифметическое элементов массива, заполненного случайными числами от 6 до 21. Размерность массива вводится с клавиатуры. Вывести на экран все элементы.

bocmanlera bocmanlera    2   20.03.2020 03:02    2

Ответы
goshan14 goshan14  12.10.2020 01:34

PascalABC.Net

Varian 1:

begin  var n := ReadInteger('Введите размер массива');  var a := ArrRandom(n, 6, 21);  Print(a, 'Srednee: ', a.Average); end.

Varian 2:

var  f: array[1..100] of integer;  i, sum, N: integer;  srednee: real; begin  Writeln('Введите размер массива: ');  Read(N);  sum := 0;  randomize;  for i := 1 to N do  begin    f[i] := random(6, 21);    write(f[i], ' ');    sum := sum + f[i];  end;  srednee := sum / n;  writeln('Srednee: ', srednee:3:3); end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика