Нужно составить программу в паскале.

заполнить одномерный массив с клавиатуры, отсортировать его методом пузырька и вывести на экран.

tima3002 tima3002    3   30.06.2019 19:17    7

Ответы
Лтвет Лтвет  02.10.2020 16:29

program fantscrin;

 const n = 10;

 var i,j:integer;

     a: array [1..100] of integer;

begin

 for i:=1 to n do

 begin

   write('a[',i,'] = ');

   readln(a[i]);

 end;

 

 for i:=1 to n do

   for j:=1 to n-1 do

     if a[j] > a[j+1] then swap(a[j], a[j+1]);

     

 for i:=1 to n do

   write(a[i],' ');

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика