Нужно составить программу в паскале.

создать матрицу n-го порядка, вида:

mxnty mxnty    2   30.06.2019 19:43    5

Ответы
madinatrtyakov madinatrtyakov  24.07.2020 10:49

program raf105;

const

 n = 10;

var

 matrix: array[1..n,1..n] of integer;

begin

 for var i:=1 to n do

 begin

   for var j:=1 to n do

   begin

     if j = n-i+1 then

       matrix[i,j]:= i

     else

       matrix[i,j]:= 0;

     write(matrix[i,j]:3,' ');

   end;

   writeln;

 end;

end.

PascalABC
ПОКАЗАТЬ ОТВЕТЫ
fairytailguil fairytailguil  24.07.2020 10:49

begin

 var m := ReadInteger();

 var a := MatrGen(m, m, (i, j)-> Ord(i + j = m - 1) * (i + 1));

 a.Println;

end.

Объяснение:


Нужно составить программу в паскале. создать матрицу n-го порядка, вида:
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика