Нужно составить программу паскаль с for вывести на экран 1000; 900; ..; 100

Полина200618 Полина200618    2   28.06.2019 14:20    5

Ответы
romanajmusin520 romanajmusin520  02.10.2020 14:07
// Нужно составить программу Паскаль с for вывести на экран 1000;900;..;100 

Var i,x:word;
begin
   for i:=1000 downto 100  do //Если вместо слова to в цикле for поставить downto, то после выполнения каждого шага цикла переменная-счетчик будет не увеличиваться, а уменьшаться на единицу    
begin
       x:= i mod 100;
       if x=0 then writeln (i);
     end;
end.
ПОКАЗАТЬ ОТВЕТЫ
sonerraz sonerraz  02.10.2020 14:07
Var
   i,a : integer;
begin
a := 1100;
for i := 1 to 10 do
 begin
  a := a -100;
  writeln (a); // write (a,'; ');
end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика