Нужно составить программу обработки данной строки, позволяющую выписать все знаки сравнения и все скобки, сохранив их последовательность

ftf3 ftf3    1   03.09.2019 05:00    2

Ответы
Васютка3333 Васютка3333  06.10.2020 13:58
Теперь уже PascalABC.Net 3.2
var s:string;
i:integer;
begin
readln(s);
for i:=1 to s.Length do begin
  if ((s[i]=')') or (s[i]='(') or (s[i]='>') or (s[i]='<') or (s[i]='=')) then write(s[i]);
  end;
end.
Я надеюсь, <>=() - это все знаки, которые вы перечислили?
ПОКАЗАТЬ ОТВЕТЫ
нася12342 нася12342  06.10.2020 13:58
// PascalABC.NET 3.2, сборка 1488 от 21.06.2017
// Внимание! Если программа не работает, обновите версию!

begin
  ReadlnString('Введите строку:').MatchValues('[()=<>]').Println('')
end.

Пример
Введите строку: Пусть F(x)=3a/x+(x-1)>5x/(2-x), тогда ...
()=()>()
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика