Нужно составить программу на паскале на квадратное уравнение!

sab435 sab435    2   07.06.2019 11:10    2

Ответы
Nezhdanchik228 Nezhdanchik228  07.07.2020 08:09
Var a,b,c:integer;
x1,x2,d:real;
begin
writeln ('Введите коэффициенты уравнения:');
readln (a,b,c);
if a=0 then
writeln('уравнение не квадратное') else
begin  d:=b*b-4*a*c; 
if d<0 then
writeln ('уравнение не имеет действительных корней')
else if d=0 then
begin
x1:=-b/(2*a);
writeln('x1=x2=',x1:0:2);   
end else
if d>0 then
begin
x1:=(-b-sqrt(d))/(2*a);
x2:=(-b+sqrt(d))/(2*a);
writeln('x1=',x1:0:2,'  x2=',x2:0:2);
end;
end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика